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Why This Ebook?

SketchUp is an incredibly powerful tool for architects and interior designers, but mas-
tering it can be a challenge. That’s where this ebook comes in.

Whether you’re new to SketchUp or an experienced user, this book will provide you 
with the tools and techniques you need to create stunning 3D models and photoreal-
istic renders. We’ll cover everything from the basics of SketchUp to advanced topics 
like working with plugins and of course V-Ray.

But why write this ebook? For me, the answer is simple: I believe that SketchUp 
has the power to transform the way we design and communicate our ideas. With 
SketchUp, you can quickly and easily create 3D models that bring your designs to life, 
and then share those models with clients and colleagues using tools like Layout for 
SketchUp.

However, learning SketchUp can be a daunting task, especially for those who are new 
to 3D modeling or rendering. There are so many tools, techniques, and plugins to 
learn, and it can be overwhelming to know where to start.

That’s why I decided to write this ebook—to provide a comprehensive guide to using 
SketchUp that is accessible to all levels of users. Whether you’re a beginner looking 
to learn the basics or an experienced user looking to take your skills to the next level, 
this ebook has something for you.

And because technology is always evolving, I plan to continue updating this ebook as 
new features and plugins are released. So even if you’re already an expert in Sketch-
Up, this book will remain a valuable resource for years to come.

I hope you find this ebook to be a helpful and informative guide to using SketchUp, 
V-Ray, Layout for SketchUp, and other plugins. Happy modeling!

See you on the Inside! 
Best,
Manish 
 
Cheers!!!

https://www.sketchupguru.com/
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How to use this Interactive Ebook

This index is organized into “Categories” and “Sub Categories” as shown in the next 
page.

You can jump to any of the below categories and start learning. Or you could also 
jump into any of the sub-categories (contents) in the next page for a specific topic.

Alternatively, to search for a keyword, press Ctrl+F and type it in. Clicking on the 
green header on a page will load the corresponding video on Youtube.

In summary, use the index to find categories, click to navigate, search for keywords, 
and click on the green header to watch the video on Youtube.

Clickable Hyperlink  
(Takes you to the Video 
for each Lesson)

Let’s you return 
to the Index Page

https://www.sketchupguru.com/
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Difference b/w Sketchup - Window & Mac Versions

The SketchUp interface on Mac and Windows is similar in many ways, but there are 
some differences to note.

One key difference is the location of the menu bar. In Windows, the menu bar is locat-
ed at the top of the SketchUp window, while on Mac, the menu bar is integrated into 
the top bar of the screen.

Additionally, some of the keyboard shortcuts for SketchUp tools may differ between 
Mac and Windows, due to differences in the keyboard layouts between the two oper-
ating systems. We will look at the differences later. 

Despite these differences, the basic layout and functionality of the SketchUp inter-
face is similar on both Mac and Windows, allowing users to easily create 3D models in 
either operating system.

Hint:
Another difference is the location of 
the tray. In Windows, the tray is locat-
ed on the right side of the SketchUp 
window by default, while on Mac, 
the tray is integrated into the main 
SketchUp window and can be hidden 
or shown using the “Window” menu.

Hint:
This is the “Tray” in Sketchup for Mac

Hint: 
If you don’t find your preferences in 
Sketchup for Mac. 
Just go to “Sketchup” from your menu 
bar > “Preferences”

https://www.sketchupguru.com/
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The Line Tool

Drawing Along An Axis

The Line tool in SketchUp is used to draw straight lines between two points in your 
model. It is one of the most basic tools in SketchUp, and is often used as the founda-
tion for creating more complex shapes and forms. Here’s how to use the line tool:

1. Select the line tool from the toolbar, or press the “L” key on your keyboard. 
2. Click on a starting point for your line and release the mouse button, hover your 

mouse to the endpoint and click again to finish. 
3. You can also type in the exact length of the line in the “Measurements Box” (Value 

Control Box) at the bottom right of the screen and press Enter to create the line.
4. If you would like to draw the line along the specific axis, follow the steps below.

IMPORTANT: 
When you draw objects in Sketchup with the line tool or any other tool for that mat-
ter, it is always important to lock the line to a certain axis. This will help avoid infer-
encing lines to different endpoints and creating lines on the wrong planes or axis.

To lock your line along an axis, activate the line tool and simply use the arrow keys on 
your keyboard or the ‘shift’ key to lock while drawing. (tap and release)

Lock Along the Red Axis.

https://www.sketchupguru.com/
https://youtu.be/jfOECiQJwT0?t=77
https://youtu.be/jfOECiQJwT0?t=228
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The Material Window in Sketchup - Mac (Bucket Tool)

The Materials window in SketchUp for Mac is similar to the Windows version, with a 
few differences in the interface. Here’s an overview of how it works:

1. To open the Materials window, simply tap “B” which will activate the bucket tool 
and automatically show up the Material Editor on the right side of your screen. 

2. The UI in Materials for Mac is different when compared to windows. There are 
four categories - Color Wheel, Color Sliders, Image Palettes, Pencils & Texture 
Palettes.  

3. To apply a material to a face or group in your model, click on the material or color 
in the Materials window and then click on the face or group in your model. 

4. You can also use the Paint Bucket tool to apply materials. To do this, select the 
Paint Bucket tool from the toolbar (or press the B key), click on the material you 
want to apply in the Materials window, and then click on the face in your model. 

4

6

5

https://www.sketchupguru.com/
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Overall, the Materials window is a powerful tool for managing and applying materi-
als in your SketchUp model, regardless of whether you’re using the Mac or Windows 
version of the software. By using the Materials window, you can easily add realistic 
textures and colors to your model, which can help to enhance its visual appeal and 
communicate your design ideas more effectively.

5. To create a new material, go to “image palette” and click on the “wheel”  button in 
the Materials window. You can then choose a texture file for the material or also 
create a texture from your clipboard. 

6. You can also edit existing materials by double clicking on the material in the Mate-
rials window. This will allow you to adjust the material’s color, texture, and other 
properties.

Hint: To sample a material, acti-
vate the bucket tool, hold down 
the ‘cmd’ key and sample your 
material. Now simply apply that 
material on your new face.

https://www.sketchupguru.com/
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Vray Toolbars

V-Ray for SketchUp adds several toolbars to the SketchUp interface, which provide 
access to V-Ray’s various features and settings. 

To access the V-Ray Toolbars, simply 
go to View > Toolbars. 

And Switch on all four of the Vray 
Toolbars as shown on the right.

This is the main toolbar for V-Ray, and it contains buttons for rendering, adjusting 
settings, and accessing V-Ray’s various features. Here is a brief of the components of 
the V-Ray for SketchUp Toolbar:

1. V-Ray for Sketchup Toolbar 

1. Vray Asset Editor

4. Render Interactive

5. Render with 
Chaos Cloud

2. Chaos Cosmos

7. Lock Camera 
Orientation

9. Batch Render

11. Viewport Render 
Region

8. Chaos Cloud Batch 
Render

10. Vray Frame 
Buffer(VFB)

12. Viewport Render

3. Render

6. Start  V-Ray Vision

https://www.sketchupguru.com/
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Vray Asset Editor

The V-Ray Asset Editor is a powerful tool in V-Ray for SketchUp that provides a cen-
tralized location for managing all of the materials, textures, lights, and other assets in 
your scene. Click on the first button in your Vray for Sketchup toolbar to access the 
asset editor.

Vray Frame Buffer

Render Button

6. Render Settings

5. Textures

4. Render Elements

3. Geometry

2. Lights

1. Materials

https://www.sketchupguru.com/
https://youtu.be/eCX5FV2mIUk?t=62
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The Asset Editor can be accessed from the V-Ray toolbar or from the V-Ray menu. 
Once opened, you will see several tabs, each with a different category of assets. These 
tabs include Materials, Lights, Geometry, Textures, and Settings.

1. Materials: The Materials tab allows you to create and manage materials, with 
options to adjust their color, reflectivity, transparency, and other properties. You 
can also apply pre-made materials from the V-Ray library or import materials from 
external sources. 

2. Lights: The Lights tab allows you to add and manage different types of lights in 
your scene, including IES, Spot, Omni, Sphere, and Rectangle lights. You can also 
adjust the light properties, such as intensity, color, and cone angle, from this tab. 

3. Geometry: The Geometry tab allows you to manage 3D objects in your scene, 
including importing and exporting objects, setting up proxies, and applying fur and 
scattering effects. 

4. Texture: The Textures tab allows you to manage textures in your scene, including 
adding, modifying, and importing textures. You can also adjust the texture proper-
ties, such as the texture’s tiling, offset, and rotation. 

5. Render Elements: The render elements allow you to isolate specific aspects of 
your scene during rendering, such as reflections, shadows, or diffuse lighting. This 
enables greater control over the final output and allows for adjustments to be 
made in post-production. Each element can be customized with its own settings 
and rendered separately or combined with other elements. 

6. Settings: The Settings tab allows you to adjust global render settings, such as im-
age resolution, quality, and render elements. You can also adjust the V-Ray frame 
buffer, and configure options such as environment maps and color mapping.

Overall, the V-Ray Asset Editor is a powerful and convenient tool that allows you to 
manage all your scene assets in one place, providing easy access and efficient work-
flow for creating high-quality renders in V-Ray for SketchUp.

https://www.sketchupguru.com/
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Create the Openings

Step 1: Create the reference lines on the wall using the “Tape Measure Tool.”

Step 2: Next enter the group, draw a rectangle on top of the reference lines and use 
the push/pull tool to create the opening.

The Window can be any size. But for this 
purpose, we will give a width of about 
1500mm or 5’.

Create the Lintel at a height of about 
2100mm or 7’.

Create the Sill at about 600mm or 2’.
Lintel

Sill

1. Enter Group
3. Select Face

3. Push Face to Other 
Side

4. Or Orbit to the other 
side 

5. Click to finish create 
opening.

2. Draw Rectangle 
on Top of Face

https://www.sketchupguru.com/
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How to Model the Skirting with the Follow Me Tool?

Step 1: Draw the Path first. This will be a line along the corners of the room.

Step 2: Create the Profile 
(Face) on one corner of the 
lines.  
 
Use the Arc Tool to create the 
corner bevel of the edge

Step 3: Use the Follow Me 
Tool to create the Skirting. 
 
1. Select the path (edges) 
first. 
2. Go to Tools > Follow Me
3. Select the Face 

Now Select the four lines 
(triple click) and make it a 
group. 

https://www.sketchupguru.com/
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How to Model the Window?

1. Draw a Rectangle (R) on top 
of the opening and make it a 
group.

1. Draw another Rectangle 
inside and make it a group.

1. Draw another Rectangle 
inside and make it a group.

2. Give a glass thickness of 
6mm.

3. Apply a glass material to the 
shutter window. 

2. Enter this group and give an 
offset of 100mm (4”). Delete 
the inside face

3. Give a shutter thickness of 
50mm (2”).

Step 1: Model the Frame of the Window

Step 2: Model the Shutter Frame of the Window

Step 3: Model the Shutter Window

As a last step, select all your window components and make it a single group.

2. Enter the new group and 
give an offset (F) of 50mm 
(2”). 
Delete the inside Face

3. Give a frame thickness of 
about 100mm (4”) using the 
pushpull tool.

https://www.sketchupguru.com/
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#5: Add Proportion Guides

The proportion guides in V-Ray for SketchUp are lines and 
grids that can be displayed over your scene to help you 
create a visually balanced composition. They are based on 
the Golden Ratio and Rule of Thirds principles, and can be 
customized to your needs. 

To Access Proportion Guides, click on the green 
‘+’ button below the layers tab. And select pro-
portion guide from the bottom.

Our render is composed well already! 
 
If your focal point is not at the center, use the hand 
tool (h) and pan your scene slightly. 
 
Don’t forget to ‘update’ your scene after you’re 
done.

Tip: The rule of thirds is a composition principle that 
suggests dividing the image into thirds both horizon-
tally and vertically. Placing important elements along 
these lines can help create a visually pleasing and 
balanced composition.

Select any of 
the propor-
tion guides 
from here

https://www.sketchupguru.com/
https://youtu.be/-TUTFlxf1-E?t=360
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The History feature in V-Ray Frame Buffer (VFB) allows you to review and compare 
previous renders of your scene. It saves previous renders as separate tabs in the VFB, 
so you can easily switch back and forth between them to compare the differences in 
lighting, materials, camera angles, and other settings. This feature can be particularly 
helpful when fine-tuning your scene or when experimenting with different lighting 
and rendering setups. By comparing different versions of your renders, you can easily 
identify what works best for your project and make informed decisions about your 
final render.

Stop the interactive render & follow the steps below.

#7: Switch on History VFB

After enabling the history 
VFB, you can start adding 
your scenes to the history 

panel window of the frame 
buffer

Go to  
Options > ‘VFB Settings’ 
in the Vray Frame Buffer 

(VFB)

Click on ‘Enable’

Specify a folder to save 
the history VFB files. 
These files are called 

‘vfbl’ files.

Click on ‘save & close’

https://www.sketchupguru.com/
https://youtu.be/-TUTFlxf1-E?t=465
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PROJECT 02 BEDROOM 
DRAWINGS LAYOUT FOR 
SKETCHUP
QUICK PRESENTATIONS IN LAYOUT FOR SKETCHUP

https://www.sketchupguru.com/
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What is Layout for Sketchup?

Layout for SketchUp is a software program that helps 
you create 2D documents from your 3D models.  

It’s commonly used by architects, engineers, and con-
struction professionals to create professional presenta-
tions and construction documents. 

With Layout, you can combine your SketchUp models, 
images, text, and other graphics to create a single docu-
ment. 

You can also add annotations, dimensions, and labels to 
your documents, and use pre-made design elements like 
title blocks and logos to save time. Overall, Layout helps 
you turn your 3D models into clear, easy-to-understand 

The first step before using Layout for Sketchup is to optimize your Sketchup model.  
 
Let’s learn to fix our models before sending it to layout.

https://www.sketchupguru.com/
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3. Use Solid Inspector Tool

The Solid Inspector tool is a plugin that helps you find and fix problems in your 3D 
models, making them “watertight” or “solid”. A watertight model means that it has no 
gaps or holes in the surface, which is essential for 3D printing or exporting to other 
software.

1. Install Solid Inspector Tool 
 
Head to Extensions > Extension Manager. 
Search for Solid Inspector Tool and install 
this plugin. 

After installing the Solid Inspector exten-
sion, restart Sketchup. 

2. Select the Model and click on the “Solid 
Inspector” icon.  
 
If you don’t find this icon, go to “Tools” > 
“Solid Inspector” 
 
Or go to View > Toolbars and switch on the 
icon. 
 

3. Click on “Fix All” to fix any issues in your 
model. If it cannot be fixed automatically, 
you can tap ‘tab’ on your keyboard and it 
will zoom in to the problem area. 
 
Now you can fix that edge or face manual-
ly.

https://www.sketchupguru.com/
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Setting up Styles in Sketchup

Setting up styles before sending your model to Layout in SketchUp is essential to en-
sure that your 2D drawings and presentations are consistent with your design intent. 
Styles in SketchUp are a combination of settings that control the appearance of your 
3D model, such as line thickness, color, and shading. When you create a 2D drawing or 
presentation in Layout, you can use these styles to maintain consistency with your 3D 
model.

1. Start with the Edge Settings

Change Profiles to 1

Change Color to the above values. This will enable you to define certain objects in 
Layout in the floor plan or section by tracing with black. 

The above rgb values (128,128,128) would give the model a nice dark grey color (pen-
cil look) which is perfect for drafting in Layout.

You can update the existing style by 
clicking here.

Or you could create a new style by 
clicking here. To rename the style, sim-

ply   type in the name and tap ‘enter.’

https://www.sketchupguru.com/
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2. Edit the Face Settings

3. Edit the Background Settings

You should use the default face settings. 
 
We will change back color later on in the 
project. 
 
And by default you should use “Display 
shaded using textures.”

Change background color 
to “255,255,255” 
 
And switch off Sky

https://www.sketchupguru.com/
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